Application - Speed Issues
Incident Report for Nomisma
Resolved
The issues should now be resolved. If you're a user still facing problems with speed, please let our support team know by emailing support@nomisma.co.uk or calling 020 3021 2326.
Posted Sep 23, 2022 - 11:03 BST
Identified
We're aware of the current speed issues in the system whereby certain pages are opening at a much slower pace than normal. It's being investigated as a top priority and should be resolved soon.
Posted Sep 19, 2022 - 11:02 BST
This incident affected: Nomisma platform (Bookkeeping & VAT).